$re = '/<[^>]*>(*SKIP)(*F)|blue/';
$str = 'dont match here <span class="blue" title="This is blue!">Aqua</span>
match ablue here
okay here too <a stuff>match blue here</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);