// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<[^>]*>(*SKIP)(*F)|blue").unwrap();
let string = "dont match here <span class=\"blue\" title=\"This is blue!\">Aqua</span>
match ablue here
okay here too <a stuff>match blue here</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}