import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*>(*SKIP)(*F)|blue";
final String string = "dont match here <span class=\"blue\" title=\"This is blue!\">Aqua</span>\n"
+ "match ablue here\n"
+ "okay here too <a stuff>match blue here</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}