#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)(?P<tag>\b(?:NOTE|LEGACY|HACK|TODO|FIXME|XXX|BUG)):\s*" & @CRLF & _
"(?P<message>.*?)" & @CRLF & _
"(" & @CRLF & _
"<" & @CRLF & _
" (?P<author>(?:\w{3}\s*,\s*)*\w{3})?\s*" & @CRLF & _
" (?P<date>\d{4}-\d{2}-\d{2})?" & @CRLF & _
" (?P<flags>[pts]:\w+\b)?" & @CRLF & _
">" & @CRLF & _
")?" & @CRLF & _
"$"
Local $sString = "// NOTE: A small example" & @CRLF & _
"// HACK: Another example <ABC 2014-02-03>" & @CRLF & _
"// HACK: Another example <ABC,DEF 2014-02-03>" & @CRLF & _
"// HACK: Another example <ABC,DEF p:0>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")