re = /(?P<tag>\b(?:NOTE|LEGACY|HACK|TODO|FIXME|XXX|BUG)):\s*
(?P<message>.*?)
(
<
(?P<author>(?:\w{3}\s*,\s*)*\w{3})?\s*
(?P<date>\d{4}-\d{2}-\d{2})?
(?P<flags>[pts]:\w+\b)?
>
)?
$/xm
str = '// NOTE: A small example
// HACK: Another example <ABC 2014-02-03>
// HACK: Another example <ABC,DEF 2014-02-03>
// HACK: Another example <ABC,DEF p:0>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end