import re
regex = re.compile(r"""
(?P<tag>\b(?:NOTE|LEGACY|HACK|TODO|FIXME|XXX|BUG)):\s*
(?P<message>.*?)
(
<
(?P<author>(?:\w{3}\s*,\s*)*\w{3})?\s*
(?P<date>\d{4}-\d{2}-\d{2})?
(?P<flags>[pts]:\w+\b)?
>
)?
$
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("// NOTE: A small example\n"
"// HACK: Another example <ABC 2014-02-03>\n"
"// HACK: Another example <ABC,DEF 2014-02-03>\n"
"// HACK: Another example <ABC,DEF p:0>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")