package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?xm)(?P<tag>\b(?:NOTE|LEGACY|HACK|TODO|FIXME|XXX|BUG)):\s*
(?P<message>.*?)
(
<
(?P<author>(?:\w{3}\s*,\s*)*\w{3})?\s*
(?P<date>\d{4}-\d{2}-\d{2})?
(?P<flags>[pts]:\w+\b)?
>
)?
$`)
var str = `// NOTE: A small example
// HACK: Another example <ABC 2014-02-03>
// HACK: Another example <ABC,DEF 2014-02-03>
// HACK: Another example <ABC,DEF p:0>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}