const regex = new RegExp('(?P<tag>\\b(?:NOTE|LEGACY|HACK|TODO|FIXME|XXX|BUG)):\\s*
(?P<message>.*?)
(
<
(?P<author>(?:\\w{3}\\s*,\\s*)*\\w{3})?\\s*
(?P<date>\\d{4}-\\d{2}-\\d{2})?
(?P<flags>[pts]:\\w+\\b)?
>
)?
$', 'gm')
const str = `// NOTE: A small example
// HACK: Another example <ABC 2014-02-03>
// HACK: Another example <ABC,DEF 2014-02-03>
// HACK: Another example <ABC,DEF p:0>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}