import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<tag>\\b(?:NOTE|LEGACY|HACK|TODO|FIXME|XXX|BUG)):\\s*\n"
+ "(?P<message>.*?)\n"
+ "(\n"
+ "<\n"
+ " (?P<author>(?:\\w{3}\\s*,\\s*)*\\w{3})?\\s*\n"
+ " (?P<date>\\d{4}-\\d{2}-\\d{2})?\n"
+ " (?P<flags>[pts]:\\w+\\b)?\n"
+ ">\n"
+ ")?\n"
+ "$";
final String string = "// NOTE: A small example\n"
+ "// HACK: Another example <ABC 2014-02-03>\n"
+ "// HACK: Another example <ABC,DEF 2014-02-03>\n"
+ "// HACK: Another example <ABC,DEF p:0>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}