#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "UI=MessageBox.\{(.*?)\} \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+(?: \"(.*?)\" \"(.*?)\" \d+)?"
Local $sString = "UI=MessageBox {122f5622-e532-4940-b86f-642eae65a7cc} "Edit Pandora station 'Bullitnuts Radio'." "What would you like to do to this station?" 30 "Delete the station" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \"Delete the station\"" 0 "Edit the station" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \"Edit the station\"" 0 "Cancel" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \"Cancel\"" 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")