const regex = /UI=MessageBox.\{(.*?)\} \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+(?: \"(.*?)\" \"(.*?)\" \d+)?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('UI=MessageBox.\\{(.*?)\\} \\"(.*?)\\" \\"(.*?)\\" \\d+ \\"(.*?)\\" \\"(.*?)\\" \\d+ \\"(.*?)\\" \\"(.*?)\\" \\d+(?: \\"(.*?)\\" \\"(.*?)\\" \\d+)?', '')
const str = `UI=MessageBox {122f5622-e532-4940-b86f-642eae65a7cc} "Edit Pandora station 'Bullitnuts Radio'." "What would you like to do to this station?" 30 "Delete the station" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\"Delete the station\\"" 0 "Edit the station" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\"Edit the station\\"" 0 "Cancel" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\"Cancel\\"" 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}