import re
regex = re.compile(r"UI=MessageBox.\{(.*?)\} \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+(?: \"(.*?)\" \"(.*?)\" \d+)?")
test_str = "UI=MessageBox {122f5622-e532-4940-b86f-642eae65a7cc} \"Edit Pandora station 'Bullitnuts Radio'.\" \"What would you like to do to this station?\" 30 \"Delete the station\" \"AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\\"Delete the station\\\"\" 0 \"Edit the station\" \"AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\\"Edit the station\\\"\" 0 \"Cancel\" \"AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\\"Cancel\\\"\" 0"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")