use strict;
my $str = 'UI=MessageBox {122f5622-e532-4940-b86f-642eae65a7cc} "Edit Pandora station \'Bullitnuts Radio\'." "What would you like to do to this station?" 30 "Delete the station" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\"Delete the station\\"" 0 "Edit the station" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\"Edit the station\\"" 0 "Cancel" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\"Cancel\\"" 0';
my $regex = qr/UI=MessageBox.\{(.*?)\} \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+(?: \"(.*?)\" \"(.*?)\" \d+)?/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}