re = /UI=MessageBox.\{(.*?)\} \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+ \"(.*?)\" \"(.*?)\" \d+(?: \"(.*?)\" \"(.*?)\" \d+)?/
str = 'UI=MessageBox {122f5622-e532-4940-b86f-642eae65a7cc} "Edit Pandora station \'Bullitnuts Radio\'." "What would you like to do to this station?" 30 "Delete the station" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\"Delete the station\\"" 0 "Edit the station" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\"Edit the station\\"" 0 "Cancel" "AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\"Cancel\\"" 0'
# Print the match result
str.match(re) do |match|
puts match.to_s
end