import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "UI=MessageBox.\\{(.*?)\\} \\\"(.*?)\\\" \\\"(.*?)\\\" \\d+ \\\"(.*?)\\\" \\\"(.*?)\\\" \\d+ \\\"(.*?)\\\" \\\"(.*?)\\\" \\d+(?: \\\"(.*?)\\\" \\\"(.*?)\\\" \\d+)?";
final String string = "UI=MessageBox {122f5622-e532-4940-b86f-642eae65a7cc} \"Edit Pandora station 'Bullitnuts Radio'.\" \"What would you like to do to this station?\" 30 \"Delete the station\" \"AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\\"Delete the station\\\"\" 0 \"Edit the station\" \"AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\\"Edit the station\\\"\" 0 \"Cancel\" \"AckButton 122f5622-e532-4940-b86f-642eae65a7cc \\\"Cancel\\\"\" 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}