#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mU)^(vertretung)?.*payback+\W++[a-z]?"
Local $sString = "payback/" & @CRLF & _
"payback/?" & @CRLF & _
"payback/?AZMEDID=123" & @CRLF & _
"payback/?AZMEDID=123#abd" & @CRLF & _
"payback/#abd" & @CRLF & _
"payback/DoNOTmatchthis1" & @CRLF & _
"payback" & @CRLF & _
"paybackdonotmatchthis" & @CRLF & _
"vertretung/daisy.maus/payback/" & @CRLF & _
"vertretung/daisy.maus/payback" & @CRLF & _
"vertretung/daisy.maus/payback/?AZMEDID=123" & @CRLF & _
"vertretung/daisy.maus/payback/?AZMEDID=123#abd" & @CRLF & _
"vertretung/daisy.maus/payback/#abd" & @CRLF & _
"vertretung/daisy.maus/payback/DoNOTmatchthis1" & @CRLF & _
"vertretung/daisy.maus/paybackDoNOTmatchthis" & @CRLF & _
"vertretung/daisy.maus/payback/# "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")