// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mU)^(vertretung)?.*payback+\W++[a-z]?").unwrap();
let string = "payback/
payback/?
payback/?AZMEDID=123
payback/?AZMEDID=123#abd
payback/#abd
payback/DoNOTmatchthis1
payback
paybackdonotmatchthis
vertretung/daisy.maus/payback/
vertretung/daisy.maus/payback
vertretung/daisy.maus/payback/?AZMEDID=123
vertretung/daisy.maus/payback/?AZMEDID=123#abd
vertretung/daisy.maus/payback/#abd
vertretung/daisy.maus/payback/DoNOTmatchthis1
vertretung/daisy.maus/paybackDoNOTmatchthis
vertretung/daisy.maus/payback/# ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}