re = /^(vertretung)?.*payback+\W++[a-z]?/m
str = 'payback/
payback/?
payback/?AZMEDID=123
payback/?AZMEDID=123#abd
payback/#abd
payback/DoNOTmatchthis1
payback
paybackdonotmatchthis
vertretung/daisy.maus/payback/
vertretung/daisy.maus/payback
vertretung/daisy.maus/payback/?AZMEDID=123
vertretung/daisy.maus/payback/?AZMEDID=123#abd
vertretung/daisy.maus/payback/#abd
vertretung/daisy.maus/payback/DoNOTmatchthis1
vertretung/daisy.maus/paybackDoNOTmatchthis
vertretung/daisy.maus/payback/# '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end