using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(vertretung)?.*payback+\W++[a-z]?";
string input = @"payback/
payback/?
payback/?AZMEDID=123
payback/?AZMEDID=123#abd
payback/#abd
payback/DoNOTmatchthis1
payback
paybackdonotmatchthis
vertretung/daisy.maus/payback/
vertretung/daisy.maus/payback
vertretung/daisy.maus/payback/?AZMEDID=123
vertretung/daisy.maus/payback/?AZMEDID=123#abd
vertretung/daisy.maus/payback/#abd
vertretung/daisy.maus/payback/DoNOTmatchthis1
vertretung/daisy.maus/paybackDoNOTmatchthis
vertretung/daisy.maus/payback/# ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}