import re
regex = re.compile(r"^(vertretung)?.*payback+\W++[a-z]?", flags=re.MULTILINE)
test_str = ("payback/\n"
"payback/?\n"
"payback/?AZMEDID=123\n"
"payback/?AZMEDID=123#abd\n"
"payback/#abd\n"
"payback/DoNOTmatchthis1\n"
"payback\n"
"paybackdonotmatchthis\n"
"vertretung/daisy.maus/payback/\n"
"vertretung/daisy.maus/payback\n"
"vertretung/daisy.maus/payback/?AZMEDID=123\n"
"vertretung/daisy.maus/payback/?AZMEDID=123#abd\n"
"vertretung/daisy.maus/payback/#abd\n"
"vertretung/daisy.maus/payback/DoNOTmatchthis1\n"
"vertretung/daisy.maus/paybackDoNOTmatchthis\n"
"vertretung/daisy.maus/payback/# ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")