import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(vertretung)?.*payback+\\W++[a-z]?";
final String string = "payback/\n"
+ "payback/?\n"
+ "payback/?AZMEDID=123\n"
+ "payback/?AZMEDID=123#abd\n"
+ "payback/#abd\n"
+ "payback/DoNOTmatchthis1\n"
+ "payback\n"
+ "paybackdonotmatchthis\n"
+ "vertretung/daisy.maus/payback/\n"
+ "vertretung/daisy.maus/payback\n"
+ "vertretung/daisy.maus/payback/?AZMEDID=123\n"
+ "vertretung/daisy.maus/payback/?AZMEDID=123#abd\n"
+ "vertretung/daisy.maus/payback/#abd\n"
+ "vertretung/daisy.maus/payback/DoNOTmatchthis1\n"
+ "vertretung/daisy.maus/paybackDoNOTmatchthis\n"
+ "vertretung/daisy.maus/payback/# ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}