const regex = /^(vertretung)?.*payback+\W++[a-z]?/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(vertretung)?.*payback+\\W++[a-z]?', 'mg')
const str = `payback/
payback/?
payback/?AZMEDID=123
payback/?AZMEDID=123#abd
payback/#abd
payback/DoNOTmatchthis1
payback
paybackdonotmatchthis
vertretung/daisy.maus/payback/
vertretung/daisy.maus/payback
vertretung/daisy.maus/payback/?AZMEDID=123
vertretung/daisy.maus/payback/?AZMEDID=123#abd
vertretung/daisy.maus/payback/#abd
vertretung/daisy.maus/payback/DoNOTmatchthis1
vertretung/daisy.maus/paybackDoNOTmatchthis
vertretung/daisy.maus/payback/# `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}