# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<cfset\b[^>]*)(?<!\\/)>/\1\/>/gm;t' <<< "<cfset var1=\"#db_var1#\">
<cfset var1=\"#db_var1#\"/>"