use strict;
my $str = '<cfset var1="#db_var1#">
<cfset var1="#db_var1#"/>';
my $regex = qr~(<cfset\b[^>]*)(?<!\/)>~mp;
my $subst = '\\1/>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";