import Foundation
let pattern = #"(<cfset\b[^>]*)(?<!\/)>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<cfset var1="#db_var1#">
<cfset var1="#db_var1#"/>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1/>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)