# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<cfset\b[^>]*)(?<!\/)>"
test_str = ("<cfset var1=\"#db_var1#\">\n"
"<cfset var1=\"#db_var1#\"/>")
subst = "\\1/>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.