const regex = new RegExp('(<cfset\\b[^>]*)(?<!\\/)>', 'gm')
const str = `<cfset var1="#db_var1#">
<cfset var1="#db_var1#"/>`;
const subst = `\1/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);