$re = '~(<cfset\b[^>]*)(?<!\/)>~m';
$str = '<cfset var1="#db_var1#">
<cfset var1="#db_var1#"/>';
$subst = "\1/>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;