import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^][]+)\\](\\(((?:[^()]+|(?2))+)\\))";
final String string = "It's very easy to make some words **bold** and other words *italic* with Markdown. You can even [link to Google!](http://google.com)\n"
+ "[a link](https://www.wiki.com/atopic_(subtopic))\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}