// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[([^][]+)\](\(((?:[^()]+|(?2))+)\))").unwrap();
let string = "It's very easy to make some words **bold** and other words *italic* with Markdown. You can even [link to Google!](http://google.com)
[a link](https://www.wiki.com/atopic_(subtopic))
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}