import re
regex = re.compile(r"\[([^][]+)\](\(((?:[^()]+|(?2))+)\))", flags=re.MULTILINE)
test_str = ("It's very easy to make some words **bold** and other words *italic* with Markdown. You can even [link to Google!](http://google.com)\n"
"[a link](https://www.wiki.com/atopic_(subtopic))\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")