using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\t*)(\/\*\*\n\s*\*\s.*)((?:\n\s*\*(?!\s@since).*)*)\/";
string substitution = @"$1$2\n$1 * \n$1 * @since 3.1$3/";
string input = @" /**
* PLL_Xliff_Import constructor.
*/
/**
* Get errors from validating the xliff scheme and display them
*
* @return string
*/
/**
* Parses an XML response body.
*
* @since 3.0.0
*
* @param DOMDocument $document A HTML document parsed by PHP DOMDocument.
*
* @return void
*/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}