import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\t*)(\\/\\*\\*\\n\\s*\\*\\s.*)((?:\\n\\s*\\*(?!\\s@since).*)*)\\/";
final String string = " /**\n"
+ " * PLL_Xliff_Import constructor.\n"
+ " */\n\n"
+ " /**\n"
+ " * Get errors from validating the xliff scheme and display them\n"
+ " *\n"
+ " * @return string\n"
+ " */\n\n"
+ " /**\n"
+ " * Parses an XML response body.\n"
+ " *\n"
+ " * @since 3.0.0\n"
+ " *\n"
+ " * @param DOMDocument $document A HTML document parsed by PHP DOMDocument.\n"
+ " *\n"
+ " * @return void\n"
+ " */";
final String subst = "$1$2\\n$1 * \\n$1 * @since 3.1$3/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}