import Foundation
let pattern = #"(^\t*)(\/\*\*\n\s*\*\s.*)((?:\n\s*\*(?!\s@since).*)*)\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/**
* PLL_Xliff_Import constructor.
*/
/**
* Get errors from validating the xliff scheme and display them
*
* @return string
*/
/**
* Parses an XML response body.
*
* @since 3.0.0
*
* @param DOMDocument $document A HTML document parsed by PHP DOMDocument.
*
* @return void
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2\n$1 * \n$1 * @since 3.1$3/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)