#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?!(.(..)+)\1*$)"
Local $sString = "x" & @CRLF & _
"xx" & @CRLF & _
"xxxx" & @CRLF & _
"xxxxxxxx" & @CRLF & _
"xxxxxxxxxxxxxxxx" & @CRLF & _
"xx…(32)…xx" & @CRLF & _
"xx…(64)…xx" & @CRLF & _
"xx…(128)…xx" & @CRLF & _
"xx…(256)…xx" & @CRLF & _
"xx…(512)…xx" & @CRLF & _
"xx…(1024)…xx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")