const regex = /^(?!(.(..)+)\1*$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(.(..)+)\\1*$)', '')
const str = `x
xx
xxxx
xxxxxxxx
xxxxxxxxxxxxxxxx
xx…(32)…xx
xx…(64)…xx
xx…(128)…xx
xx…(256)…xx
xx…(512)…xx
xx…(1024)…xx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}