$re = '/^(?!(.(..)+)\1*$)/';
$str = 'x
xx
xxxx
xxxxxxxx
xxxxxxxxxxxxxxxx
xx…(32)…xx
xx…(64)…xx
xx…(128)…xx
xx…(256)…xx
xx…(512)…xx
xx…(1024)…xx';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);