re = /^(?!(.(..)+)\1*$)/
str = 'x
xx
xxxx
xxxxxxxx
xxxxxxxxxxxxxxxx
xx…(32)…xx
xx…(64)…xx
xx…(128)…xx
xx…(256)…xx
xx…(512)…xx
xx…(1024)…xx'
# Print the match result
str.match(re) do |match|
puts match.to_s
end