import Foundation
let pattern = #"^(?!(.(..)+)\1*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
x
xx
xxxx
xxxxxxxx
xxxxxxxxxxxxxxxx
xx…(32)…xx
xx…(64)…xx
xx…(128)…xx
xx…(256)…xx
xx…(512)…xx
xx…(1024)…xx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}