import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(.(..)+)\\1*$)";
final String string = "x\n"
+ "xx\n"
+ "xxxx\n"
+ "xxxxxxxx\n"
+ "xxxxxxxxxxxxxxxx\n"
+ "xx…(32)…xx\n"
+ "xx…(64)…xx\n"
+ "xx…(128)…xx\n"
+ "xx…(256)…xx\n"
+ "xx…(512)…xx\n"
+ "xx…(1024)…xx";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}