import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<line>[^\\)]+\\)\\n\\N+)";
final String string = "Content-Transfer-Encoding: 7bit\n"
+ " Scheduled job console-context --evs 1 quota list --verbose FIRST_FS produced the following output:\n"
+ " Type : Explicit\n"
+ " Target : ViVol: VOL_ABC\n"
+ " Usage : 100 GB\n"
+ " Limit : 500 GB (Hard)\n"
+ " Last modified : 2010-12-19 04:56:50.834383000+00:00\n"
+ " Type : Explicit\n"
+ " Target : ViVol: VOL_XYZ\n"
+ " Usage : 609 GB\n"
+ " Limit : 3 TB (Hard)\n"
+ " Last modified : 2010-12-21 04:04:23.757073000+00:00\n"
+ " Type : Explicit\n"
+ " Target : ViVol: VOL_123\n"
+ " Usage : 609 GB\n"
+ " Limit : 3 TB (Hard)\n"
+ " Last modified : 2010-12-21 04:04:23.757073000+00:00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}