import Foundation
let pattern = #"(?<line>[^\)]+\)\n\N+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Content-Transfer-Encoding: 7bit
Scheduled job console-context --evs 1 quota list --verbose FIRST_FS produced the following output:
Type : Explicit
Target : ViVol: VOL_ABC
Usage : 100 GB
Limit : 500 GB (Hard)
Last modified : 2010-12-19 04:56:50.834383000+00:00
Type : Explicit
Target : ViVol: VOL_XYZ
Usage : 609 GB
Limit : 3 TB (Hard)
Last modified : 2010-12-21 04:04:23.757073000+00:00
Type : Explicit
Target : ViVol: VOL_123
Usage : 609 GB
Limit : 3 TB (Hard)
Last modified : 2010-12-21 04:04:23.757073000+00:00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)