#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\<option.*value="([a-z]*)".*(?=selected=(?:'|")selected(?:'|")).*$"
Local $sString = "<select name="cycle" id="cycle" > <option value="2113" > Dec 30, 2021 - Jan 26, 2022 [2113]* (Previous) </option> <option value="2201" selected > Jan 27 - Feb 23, 2022 [2201] (Current) </option> </select>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")