import Foundation
let pattern = #"^.*\<option.*value="([a-z]*)".*(?=selected=(?:'|")selected(?:'|")).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<select name="cycle" id="cycle" > <option value="2113" > Dec 30, 2021 - Jan 26, 2022 [2113]* (Previous) </option> <option value="2201" selected > Jan 27 - Feb 23, 2022 [2201] (Current) </option> </select>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)