$re = '/^.*\<option.*value="([a-z]*)".*(?=selected=(?:\'|")selected(?:\'|")).*$/m';
$str = '<select name="cycle" id="cycle" > <option value="2113" > Dec 30, 2021 - Jan 26, 2022 [2113]* (Previous) </option> <option value="2201" selected > Jan 27 - Feb 23, 2022 [2201] (Current) </option> </select>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);