import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\<option.*value=\"([a-z]*)\".*(?=selected=(?:'|\")selected(?:'|\")).*$";
final String string = "<select name=\"cycle\" id=\"cycle\" > <option value=\"2113\" > Dec 30, 2021 - Jan 26, 2022 [2113]* (Previous) </option> <option value=\"2201\" selected > Jan 27 - Feb 23, 2022 [2201] (Current) </option> </select>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}