using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\<option.*value=""([a-z]*)"".*(?=selected=(?:'|"")selected(?:'|"")).*$";
string input = @"<select name=""cycle"" id=""cycle"" > <option value=""2113"" > Dec 30, 2021 - Jan 26, 2022 [2113]* (Previous) </option> <option value=""2201"" selected > Jan 27 - Feb 23, 2022 [2201] (Current) </option> </select>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}