const regex = /^.*\<option.*value="([a-z]*)".*(?=selected=(?:'|")selected(?:'|")).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\<option.*value="([a-z]*)".*(?=selected=(?:\'|")selected(?:\'|")).*$', 'gm')
const str = `<select name="cycle" id="cycle" > <option value="2113" > Dec 30, 2021 - Jan 26, 2022 [2113]* (Previous) </option> <option value="2201" selected > Jan 27 - Feb 23, 2022 [2201] (Current) </option> </select>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}