use strict;
my $str = '<select name="cycle" id="cycle" > <option value="2113" > Dec 30, 2021 - Jan 26, 2022 [2113]* (Previous) </option> <option value="2201" selected > Jan 27 - Feb 23, 2022 [2201] (Current) </option> </select>';
my $regex = qr/^.*\<option.*value="([a-z]*)".*(?=selected=(?:'|")selected(?:'|")).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}