#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:\d+%(?: |for)+([A-Z](?:[\w\.♀♂']|(?: (?=[A-Z])))+))+)[, &]*"
Local $sString = "95% for Pikachu, 92% for Mr. Mime" & @CRLF & _
"70% for Paras & 100% Arcanine" & @CRLF & _
"99% Diglett, 40% Dugtrio" & @CRLF & _
"10% Squirtle, 100% for Alakazam" & @CRLF & _
"30% Metopod & 99% Nidoran♂"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")